Im Gegensatz zu früheren Windows-Versionen sind unter Vista / Win 7 Schreibzugriffe auf viele Bereiche des Rechners für Anwendungen gesperrt. Damit Programme, die für ältere Windows-Versionen entwickelt wurden, auch auf Vista laufen, enthält Vista Funktionen, die diese Schreibzugriffe „umleiten“. So laufen ältere Programme zwar, aber es tauchen gelegentlich Probleme auf, deren Ursachen schwer nachvollziehbar sind.
Problem 1:
Fehlermeldung beim Einlesen eines Backups; zum Beispiel: „Fehler aufgetreten: ….. (Access is denied)“
Ursache:
Vista verweigert den Schreibzugriff, der zum Einlesen des Backups nötig ist
Problem 2:
Ein Backup wird erstellt und auf einem anderen Rechner eingelesen. Wenn das Programm gestartet wird, werden jedoch keine Daten angezeigt.
Ursache:
Unsere Programm schreiben Ihre Daten in eine Datenbank. Ohne dass das Programm davon erfährt, sperrt Vista jedoch den Schreibzugriff auf die Datenbank und legt eine Kopie davon an, in die das Programm stattdessen schreibt.
Erstellt man jetzt ein Backup, wird lediglich die leere Datenbank in dem Backup gesichert. Die von Vista erstellte Kopie der Datenbank, in der sich die eigentlichen Daten befinden, wird nicht gesichert.
Dies geschieht automatisch im Hintergrund, ohne dass die betroffenen Programme davon Kenntnis erhalten. Daher ist es nicht möglich, eine Fehlermeldung oder einen Warnhinweis anzuzeigen.
Lösung:
Um diese Probleme zu vermeiden, haben wir unsere Programme angepasst: Die Datenbank wird in den eigenen Benutzerordner ausgelagert, in dem grundsätzlich volle Schreibrechte bestehen.
Die Updates sind erhältlich über den Updateclub (Einstellungen → Updates)
oder als eigenständiger Download für folgende Programme:
Vereinsscout und Vereinsverwaltung 2 von Chip
Verwaltungsscout und Verwaltungsscout Business
Bitte installieren Sie die entsprechenden Updates und beachten Sie dabei folgende Hinweise:
Vor der Installation eines Updates muss das Programm beendet worden sein; idealerweise wird der Rechner zuvor neu gestartet
Der Installations-Ordner wird automatisch erkannt; sollte aber trotzdem überprüft und wenn nötig angepasst werden (insbesondere, wenn Sie den Ordner geändert haben)
Nach der Installation: Starten Sie das Programm; während des 1. Starts nach dem Update wird die Datenbank umgelagert
Prüfen Sie, ob die Daten noch vorhanden sind; beenden und starten Sie das Programm ggf. noch ein zweites Mal
Wenn alles geklappt hat, erstellen Sie ein aktuelles Backup Ihrer Daten; das Backup-Programm wurde im Zuge des Updates angepasst (Version 2.0)
Falls die Daten im Programm nicht mehr angezeigt werden sollten → installieren Sie das Programm NICHT neu, um Datenverlust zu vermeiden! Wenden Sie sich stattdessen an den Support oder fahren Sie mit dem folgenden Abschnitt „Für Fortgeschrittene Benutzer“ fort
Informationen für fortgeschrittene Benutzer:
Die durch Vista angelegte Kopie der Datenbankdateien, in der Ihre Programmdaten enthalten sind, befindet sich hier:
C:\Users\MEIN_NAME\AppData\Local\VirtualStore\Program Files\PROGRAMMNAME\mysql\data\kita
Nach der Installation des Updates befindet sich die vom Programm verwendete Datenbank hier:
C:\Users\MEIN_NAME\Scoutsystems\PROGRAMMNAME\data\kita
Falls die Umlagerung der Datenbank nicht wie erwartet funktioniert hat, können Sie manuell die Dateien aus dem 1. Ordner zum 2. kopieren (während das Programm beendet ist).